При установке на VPS - ошибки Mongo



  • при проверке статуса Монго выдает такое

    root@vps-33479:~# sudo systemctl status mongod
    ● mongod.service - MongoDB Database Server
    Loaded: loaded (/lib/systemd/system/mongod.service; disabled; vendor preset: enabled)
    Active: failed (Result: exit-code) since Wed 2020-04-01 21:33:47 EEST; 11s ago
    Docs: https://docs.mongodb.org/manual
    Process: 24605 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=exited, status=2)
    Main PID: 24605 (code=exited, status=2)

    Apr 01 21:33:47 vps-33479.vps-default-host.net systemd[1]: Started MongoDB Database Server.
    Apr 01 21:33:47 vps-33479.vps-default-host.net mongod[24605]: Error parsing YAML config file: yaml-cpp: error at line 11, column 4: end of map
    Apr 01 21:33:47 vps-33479.vps-default-host.net mongod[24605]: try '/usr/bin/mongod --help' for more information
    Apr 01 21:33:47 vps-33479.vps-default-host.net systemd[1]: mongod.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
    Apr 01 21:33:47 vps-33479.vps-default-host.net systemd[1]: mongod.service: Failed with result 'exit-code'.

    # mongod.conf
    
    # for documentation of all options, see:
    #   http://docs.mongodb.org/manual/reference/configuration-options/
    
    # Where and how to store data.
    storage:
      dbPath: /var/lib/mongodb
      journal:
        enabled: true
       engine: wiredTiger
    #  mmapv1:
    #  wiredTiger:
    
    # where to write logging data.
    systemLog:
      destination: file
      logAppend: true
      path: /var/log/mongodb/mongod.log
    
    # network interfaces
    net:
      port: 27017
      bindIp: 0.0.0.0
    
    
    # how the process runs
    processManagement:
      timeZoneInfo: /usr/share/zoneinfo
    
    security:
      authorization: enabled
    
    #operationProfiling:
    
    #replication:
    
    #sharding:
    
    ## Enterprise-Only Options:
    
    
    


  • Я думаю не так важно что выдает при проверке статуса, важно что выдает при старте.



  • @Admin при старте тоже странно, потому что в конфиге проставили 0.0.0.0 .....
    xx85@vps-33479:~$ mongo
    MongoDB shell version v4.2.5
    connecting to: mongodb://127.0.0.1:27017/?compressors=disabled&gssapiServiceName=mongodb
    2020-04-01T22:00:37.905+0300 E QUERY [js] Error: couldn't connect to server 127.0.0.1:27017, connection attempt failed: SocketException: Error connecting to 127.0.0.1:27017 :: caused by :: Connection refused :
    connect@src/mongo/shell/mongo.js:341:17
    @(connect):2:6
    2020-04-01T22:00:37.907+0300 F - [main] exception: connect failed
    2020-04-01T22:00:37.907+0300 E - [main] exiting with code 1



  • mongo - это не команда для запуска.

    Вот команда для старта:

    service mongod start
    

    После старта можно посмотреть статус:

    service mongod status
    


  • @Admin я не могу админа создать - на статусе блочит ошибкой



  • я не могу админа создать - на статусе блочит ошибкой

    Не понял что это значит. Не нужно создавать админа на каком-то статусе. Нужно запустить БД, а потом подключить к ней через Mongo Shell (команда mongo).



  • @Admin ну я не знаю куда вставить эти данные

    db.createUser(
        {
            user: "root",
            pwd: "PASSWORD",
            roles: [{role:"root", db:"admin"}]
        }
    )
    

    вот код

    root@vps-33479:~# service mongod status
    ● mongod.service - MongoDB Database Server
       Loaded: loaded (/lib/systemd/system/mongod.service; disabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Wed 2020-04-01 23:06:44 EEST; 1min 17s ago
         Docs: https://docs.mongodb.org/manual
      Process: 26656 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=exited, status=2)
     Main PID: 26656 (code=exited, status=2)
    
    Apr 01 23:06:44 vps-33479.vps-default-host.net systemd[1]: Started MongoDB Database Server.
    Apr 01 23:06:44 vps-33479.vps-default-host.net mongod[26656]: Unrecognized option: storage.journal.ngine
    Apr 01 23:06:44 vps-33479.vps-default-host.net mongod[26656]: try '/usr/bin/mongod --help' for more information
    Apr 01 23:06:44 vps-33479.vps-default-host.net systemd[1]: mongod.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
    Apr 01 23:06:44 vps-33479.vps-default-host.net systemd[1]: mongod.service: Failed with result 'exit-code'.
    root@vps-33479:~# service mongod start
    root@vps-33479:~# service mongod status
    ● mongod.service - MongoDB Database Server
       Loaded: loaded (/lib/systemd/system/mongod.service; disabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Wed 2020-04-01 23:08:10 EEST; 1s ago
         Docs: https://docs.mongodb.org/manual
      Process: 26719 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=exited, status=2)
     Main PID: 26719 (code=exited, status=2)
    
    Apr 01 23:08:10 vps-33479.vps-default-host.net systemd[1]: Started MongoDB Database Server.
    Apr 01 23:08:10 vps-33479.vps-default-host.net mongod[26719]: Unrecognized option: storage.journal.ngine
    Apr 01 23:08:10 vps-33479.vps-default-host.net mongod[26719]: try '/usr/bin/mongod --help' for more information
    Apr 01 23:08:10 vps-33479.vps-default-host.net systemd[1]: mongod.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
    Apr 01 23:08:10 vps-33479.vps-default-host.net systemd[1]: mongod.service: Failed with result 'exit-code'.
    root@vps-33479:~# mongo
    MongoDB shell version v4.2.5
    connecting to: mongodb://127.0.0.1:27017/?compressors=disabled&gssapiServiceName=mongodb
    2020-04-01T23:08:27.241+0300 E  QUERY    [js] Error: couldn't connect to server 127.0.0.1:27017, connection attempt failed: SocketException: Error connecting to 127.0.0.1:27017 :: caused by :: Connection refused :
    connect@src/mongo/shell/mongo.js:341:17
    @(connect):2:6
    2020-04-01T23:08:27.243+0300 F  -        [main] exception: connect failed
    2020-04-01T23:08:27.243+0300 E  -        [main] exiting with code 1
    root@vps-33479:~# use admin
    
    Command 'use' not found, did you mean:
    
      command 'nse' from deb ns2
      command 'ase' from deb ase
      command 'muse' from deb muse
      command 'fuse' from deb fuse-emulator-gtk
      command 'fuse' from deb fuse-emulator-sdl
    
    Try: apt install <deb name>
    
    root@vps-33479:~#
    
    


  • Всё же написано. Зачем продолжать, если БД не запускается?

    Error: couldn't connect to server 127.0.0.1:27017

    Unrecognized option: storage.journal.ngine

    storage:
      dbPath: /var/lib/mongodb
      journal:
        enabled: true
       engine: wiredTiger
    

    Важны пробелы. Сделайте нормальное выравнивание.
    Должно быть так:

    storage:
      dbPath: /var/lib/mongodb
      journal:
        enabled: true
      engine: wiredTiger
    


  • @Admin спасибо, все получилось
    а что дальше? при переходе на главную сайта указано это
    и даже при переходе по http://..*.1/setup

    Welcome to nginx!
    If you see this page, the nginx web server is successfully installed and working. Further configuration is required.
    
    For online documentation and support please refer to nginx.org.
    Commercial support is available at nginx.com.
    
    Thank you for using nginx.
    


  • при переходе на главную сайта указано это

    Значит Nginx не настроен. Продолжать идти по инструкции.



  • @Admin ну я даже не знаю..... все делал по инструкции.
    а как лог ошибок посмотреть

    root@vps-33479:~# ufw status
    Status: active
    
    To                         Action      From
    --                         ------      ----
    OpenSSH                    ALLOW       Anywhere
    Nginx HTTP                 ALLOW       Anywhere
    Nginx HTTPS                ALLOW       Anywhere
    OpenSSH (v6)               ALLOW       Anywhere (v6)
    Nginx HTTP (v6)            ALLOW       Anywhere (v6)
    Nginx HTTPS (v6)           ALLOW       Anywhere (v6)
    
    root@vps-33479:~#
    
    


  • @Alex18

    и даже при переходе по http://..*.1/setup

    Похоже Вы используете IP адрес сервера для доступа по HTTP, а инструкция предполагает, что у вас есть доменное имя.

    Если доменного имени нет, то надо удалить симлинк

    rm /etc/nginx/sites-enabled/default
    

    Создать конф. файл

    touch /etc/nginx/sites-available/my_site.conf
    

    содержание взять отсюда:
    https://shopker.org/documentation/web-server-settings

    Вместо строк:

    listen 80;
    server_name shopkeeper4;
    

    вставить:

    listen 127.0.0.1:80 default_server;
    listen [::]:80 default_server;
    

    отредактировать путь папки сайта.
    Создать симлинк, как написано в инструкции:

    ln -s /etc/nginx/sites-available/my_site.conf /etc/nginx/sites-enabled/my_site.conf
    

    Перезагрузить Nginx:

    /etc/init.d/nginx restart
    


  • @Admin в папке www находится html и shopkeeper4
    и насколько я понял то запускается файл из html
    index.nginx-debian.html

    <!DOCTYPE html>
    <html>
    <head>
    <title>Welcome to nginx!</title>
    <style>
        body {
            width: 35em;
            margin: 0 auto;
            font-family: Tahoma, Verdana, Arial, sans-serif;
        }
    </style>
    </head>
    <body>
    <h1>Welcome to nginx!</h1>
    <p>If you see this page, the nginx web server is successfully installed and
    working. Further configuration is required.</p>
    
    <p>For online documentation and support please refer to
    <a href="http://nginx.org/">nginx.org</a>.<br/>
    Commercial support is available at
    <a href="http://nginx.com/">nginx.com</a>.</p>
    
    <p><em>Thank you for using nginx.</em></p>
    </body>
    </html>
    
    

    и я не совсем понял - а где привязать доменное имя?
    в хостинге все было понятно, но тут извините - я не знаю, и в инструкции не было



  • и я не совсем понял - а где привязать доменное имя?

    У регистратора доменного имени нужно указать NS-адреса вашего сервера. Там, где регистрировали имя, должна быть панель управления. После того, как доменное имя будет указывать на ваш сервер, будут работать параметры из конф. файлов Nginx, там указано что открывать для какого домена.



  • @Admin NS проставленны - все ок.
    а вот тут снова та же заставка

    Welcome to nginx!
    


  • а вот тут снова та же заставка

    Для кого я писал ответы выше? Открывается тот файл, который настроен в конфигурации. Сейчас, похоже, у вас срабатывает конфигурация default, как я писал выше.

    Свою конфигурацию вы не показали.

    все делал по инструкции.

    Значит, как и раньше, сделали что-то не так. Как я могу увидеть что вы сделали?



  • @Admin Извините - отвлекли немного на пару дней))
    что то - ничего не получается - сайт freyamebel.com
    вот конфигурационный файл - shopkeeper4.conf

    server {
        listen 185.233.129.169:80 default_server;
        server_name shopkeeper4;
        root /var/www/freyamebel.com/public;
    
        location / {
            try_files $uri /index.php$is_args$args;
        }
    
        location ~ ^/(index|check)\.php(/|$) {
            fastcgi_pass unix:/run/php/php7.3-fpm.sock;
            fastcgi_split_path_info ^(.+\.php)(/.*)$;
            include fastcgi_params;
            fastcgi_param SCRIPT_FILENAME $realpath_root$fastcgi_script_name;
            fastcgi_param DOCUMENT_ROOT $realpath_root;
            internal;
    
    


  • Это весь конфиг или кусок?

    Вместо

    listen 185.233.129.169:80 default_server;
    server_name shopkeeper4;
    

    должно быть:

    listen 127.0.0.1:80;
    server_name freyamebel.com;
    


  • @Admin сделал как написали

    server {
        listen 127.0.0.1:80;
        server_name freyamebel.com;
        root /var/www/freyamebel/public;
    
        location / {
            try_files $uri /index.php$is_args$args;
        }
    
        location ~ ^/(index|check)\.php(/|$) {
            fastcgi_pass unix:/run/php/php7.3-fpm.sock;
            fastcgi_split_path_info ^(.+\.php)(/.*)$;
            include fastcgi_params;
            fastcgi_param SCRIPT_FILENAME $realpath_root$fastcgi_script_name;
            fastcgi_param DOCUMENT_ROOT $realpath_root;
            internal;
        }
    
        location ~ \.php$ {
            return 404;
        }
    
        location = /favicon.ico {
            log_not_found off;
            access_log off;
        }
    
        location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;
        }
    
        location ~ /\. {
            deny all;
        }
    
        error_log /var/log/nginx/shopkeeper4_error.log;
        access_log /var/log/nginx/shopkeeper4_access.log;
    }
    
    

    в результате - ничего не изменилось, при переходе на главную все тот же Welcome to nginx



  • ln -s /etc/nginx/sites-available/shopkeeper4.conf /etc/nginx/sites-enabled/shopkeeper4.conf
    

    Это сделали? Nginx рестартнули после этого?

    /etc/init.d/nginx restart
    

Авторизуйтесь, чтобы ответить